$re = '~\bhttps?://[^][()\s]*(?:\[\d+][^][\s]*)*~im';
$str = 'foo [https://www.example.com/link1](https://www.example.com/link2) data
bar https://www.example.com/link3?test[0]=val data data
xyz https://www.example.com/link4] test foo
https://www.example.com/link5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);