re = /[_\w;]/m
str = 'this_isTest;sentence
this new _isTest;sentence
again _isTest; sentence'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end