const regex = /([0-9]{1,2}h)\s*([0-9]{1,2}min)*:\s*([\w\W]*?)(?=[0-9]{1,2}h\s*([0-9]{1,2}min)|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{1,2}h)\\s*([0-9]{1,2}min)*:\\s*([\\w\\W]*?)(?=[0-9]{1,2}h\\s*([0-9]{1,2}min)|$)', 'g')
const str = `1h 30min: Title
- Description Line 1
1h 31min: Title
- Description Line 1
- Description Line 2
- Description Line 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}