re = /([0-9]{1,2}h)\s*([0-9]{1,2}min)*:\s*([\w\W]*?)(?=[0-9]{1,2}h\s*([0-9]{1,2}min)|$)/
str = '1h 30min: Title
- Description Line 1
1h 31min: Title
- Description Line 1
- Description Line 2
- Description Line 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end