#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\d$)[a-zA-Z0-9]{2,}$"
Local $sString = "a" & @CRLF & _
"1" & @CRLF & _
"a1" & @CRLF & _
"aa" & @CRLF & _
"abc3" & @CRLF & _
"abc567" & @CRLF & _
"abc456d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")