$re = '/^(?=.*\d$)[a-zA-Z0-9]{2,}$/m';
$str = 'a
1
a1
aa
abc3
abc567
abc456d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);