$re = '/(?<=>(?!\\\\n))[^<>]*(?=<)/m';
$str = '<Telerik.Sitefinity.GeoLocations.Model.Address>\\n <City>Little Rock</City>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);