re = /(?<=>(?!\\n))[^<>]*(?=<)/m
str = '<Telerik.Sitefinity.GeoLocations.Model.Address>\\n <City>Little Rock</City>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end