package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((\d)\)|div(\d.?)\s-\s(\w.*?)\s`)
var str = `hello blah(1) ndnddnnn div1 - this ;sdhfdkl;a div2 - should i<;oisdjn div3 - be div4 - captured ois;s;urbb !blah aksdhflakjsfadlfjkbafa;km blah(2) ndnddnnn div35 - also ;sdhfdkl;a div24 - these i<;oisdjn div0 - need div94 - capture ois;s;urbb !blah world
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}