re = /\((\d)\)|div(\d.?)\s-\s(\w.*?)\s/
str = 'hello blah(1) ndnddnnn div1 - this ;sdhfdkl;a div2 - should i<;oisdjn div3 - be div4 - captured ois;s;urbb !blah aksdhflakjsfadlfjkbafa;km blah(2) ndnddnnn div35 - also ;sdhfdkl;a div24 - these i<;oisdjn div0 - need div94 - capture ois;s;urbb !blah world
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end