$re = '/^(?=.*)((?:\+61) ?(?:\((?=.*\)))?([2-47-8])\)?|(?:\((?=.*\)))?([0-1][2-47-8])\)?) ?-?(?=.*)((\d{1} ?-?\d{3}$)|(00 ?-?\d{4} ?-?\d{4}$)|( ?-?\d{4} ?-?\d{4}$)|(\d{2} ?-?\d{3} ?-?\d{3}$))/m';
$str = '+61 3 12345678
+61 3 1234 5678
+61 3 1234-5678
+61 (3) 12345678
+61 (3) 1234 5678
+61 (3) 1234-5678
0312345678
03 1234 5678
03-1234-5678
(03)12345678
(03) 1234 5678
(03) 1234-5678
0412345678
0412 345 678
0412-345-678
131234
131 234
131-234
130012345678
1300 1234 5678
1300-1234-5678
180012345678
Fail cases:
+61 (03) 1234-5678
+61(0289876544
(715) 867-5309
+1 661 2019-835';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);