import Foundation
let pattern = #"^(?=.*)((?:\+61) ?(?:\((?=.*\)))?([2-47-8])\)?|(?:\((?=.*\)))?([0-1][2-47-8])\)?) ?-?(?=.*)((\d{1} ?-?\d{3}$)|(00 ?-?\d{4} ?-?\d{4}$)|( ?-?\d{4} ?-?\d{4}$)|(\d{2} ?-?\d{3} ?-?\d{3}$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+61 3 12345678
+61 3 1234 5678
+61 3 1234-5678
+61 (3) 12345678
+61 (3) 1234 5678
+61 (3) 1234-5678
0312345678
03 1234 5678
03-1234-5678
(03)12345678
(03) 1234 5678
(03) 1234-5678
0412345678
0412 345 678
0412-345-678
131234
131 234
131-234
130012345678
1300 1234 5678
1300-1234-5678
180012345678
Fail cases:
+61 (03) 1234-5678
+61(0289876544
(715) 867-5309
+1 661 2019-835
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)