const regex = /(?i)(?:adafruit)(?:[0–9a-z\-_\t .]{0,20})(?:[\s|']|[\s|"]){0,3}(?:=|>|:=|<=|=>|:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?:adafruit)(?:[0–9a-z\\-_\\t .]{0,20})(?:[\\s|\']|[\\s|"]){0,3}(?:=|>|:=|<=|=>|:)', 'gm')
const str = `"adafruit_api_key" = "x-xfiu9qulytekagka60cn2ey1rrrba4"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}