const regex = new RegExp('(?<=\\d{6}\\s)([A-Z0-9]+\\b)\\s(?:([A-Z0-9]+\\b))*', 'mg')
const str = `LTUS41 KCAR 141558 AAD TMLB Forecast for the National Parks
KHNX 141001 RECHNX Weather Service San Joaquin Valley
LTUS41 KCAR 141558 AAD RR4HNX RRa
LTUS41 KCAR 141558 AAD RECHNX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}