$re = '/(?<=\d{6}\s)([A-Z0-9]+\b)\s(?:([A-Z0-9]+\b))*/m';
$str = 'LTUS41 KCAR 141558 AAD TMLB Forecast for the National Parks
KHNX 141001 RECHNX Weather Service San Joaquin Valley
LTUS41 KCAR 141558 AAD RR4HNX RRa
LTUS41 KCAR 141558 AAD RECHNX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);