package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[Gg]{1}0*\s`)
var str = `G00 X0.0 Y0.0 Z-1.0
G01 X1.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}