import re
regex = re.compile(r"[Gg]{1}0*\s", flags=re.MULTILINE)
test_str = ("G00 X0.0 Y0.0 Z-1.0\n"
"G01 X1.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")