using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[Name\](?<Name>[\s\S]*?)\[Age\](?<Age>[\s\S]*?)\[MobileNumber\](?<MN>[\s\S]*?)Billing address(?<BA>[\s\S]*?)Delivery address(?<DA>(?:\s*.*))";
string input = @"[Name]
Jhon
[Age]
45
[MobileNumber]
1020304050
Billing address Delivery address
India India";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}