import Foundation
let pattern = #"\[Name\](?<Name>[\s\S]*?)\[Age\](?<Age>[\s\S]*?)\[MobileNumber\](?<MN>[\s\S]*?)Billing address(?<BA>[\s\S]*?)Delivery address(?<DA>(?:\s*.*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[Name]
Jhon
[Age]
45
[MobileNumber]
1020304050
Billing address Delivery address
India India
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)