using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*^<a)(?=.*<\/a>$).*";
string input = @"<a href=""www.something.com"">Link</a>
words before <a href=""www.something.com"">Link</a>
<a href=""www.something.com"">Link</a> words after";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}