$re = '/(?=.*^<a)(?=.*<\/a>$).*/m';
$str = '<a href="www.something.com">Link</a>
words before <a href="www.something.com">Link</a>
<a href="www.something.com">Link</a> words after';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);