package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?Um)<.*[^\x01-\x7E]+.*>`)
var str = `aaaaa<ああ>bbb<1aaあa1>ba
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}