import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S*)?(:\\/\\/)?(?<interesting>.*)(:)?\\/";
final String string = "ap://167.172.44.255:1389/LegitimateJavaCla\n"
+ "ap://167.172.44.255:1389/La\n"
+ "ap://167.99.32.139:1389/Basic/ReverseShell/167.99.32.139/99\n"
+ "ldap://x.x.x.x.61k2ev3252274o2ek77941q85t0r9444o.interact.sh/ok6ll9m\n"
+ "ldap://c6ps4rekeidcvgqlsmsgcg37qdoyyknz4.interact.sh/a\n"
+ "ldap://c6ps4rekeidcvgqlsmsgcg37x9ayymcak.interact.sh/a\n"
+ "ldap://c6ps4ipurnhssm2608l0cg37chyyykyhk.interact.sh/a\n"
+ "ldap://c6ps4ipurnhssm2608l0cg37pdyyykbug.interact.sh/a\n"
+ "91fd9fef8958.bingsearchlib.com:39356/\n"
+ "550f7e1deaed.bingsearchlib.com:39356/a\n"
+ "2174d47e8d04.bingsearchlib.com:39356/a\n"
+ "da6d408517b9.bingsearchlib.com:39356/a\n"
+ "5463610592ef.bingsearchlib.com:39356/a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}