using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\d7]*7\D*$(?<=Coffee.*)";
string input = @"text... Coffee 7 ... more...
text... Coffee 8 ... more...
text... Coffee ... more...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}