$re = '/^[^\d7]*7\D*$(?<=Coffee.*)/m';
$str = 'text... Coffee 7 ... more...
text... Coffee 8 ... more...
text... Coffee ... more...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);