import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{([-+]?[0-9]*[.,]?[0-9]+(?:[eE][-+]?[0-9]+)?),\\s*([-+]?[0-9]*[.,]?[0-9]+(?:[eE][-+]?[0-9]+)?)\\}$";
final String string = "{1, 2}\n"
+ "{1.2, 2.3}\n"
+ "{1.2e+100, 5.678e-10}\n"
+ "{1.2E-2, -5.678E+01}\n"
+ "{+.12, +5.5e-12}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}