$re = '/^\{([-+]?[0-9]*[.,]?[0-9]+(?:[eE][-+]?[0-9]+)?),\s*([-+]?[0-9]*[.,]?[0-9]+(?:[eE][-+]?[0-9]+)?)\}$/m';
$str = '{1, 2}
{1.2, 2.3}
{1.2e+100, 5.678e-10}
{1.2E-2, -5.678E+01}
{+.12, +5.5e-12}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);