package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s;,]+`)
var str = `12f3,, 456;;;;
227- , 999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}