package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\/?].*[a-zA-Z].*$
`)
var str = `/9this can be/a/path123
/24
/23example
not a path at all
/a path/
/a path containing 2132 numbers/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}