re = /^[\/?].*[a-zA-Z].*$
/m
str = '/9this can be/a/path123
/24
/23example
not a path at all
/a path/
/a path containing 2132 numbers/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end