const regex = /^[-a-zA-Z0-9#$%'_]+(\.[-a-zA-Z0-9#$%'_]+)*@(([-a-zA-Z0-9]+)\.)+(?!\d+$)[a-zA-Z0-9]{2,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-a-zA-Z0-9#$%\'_]+(\\.[-a-zA-Z0-9#$%\'_]+)*@(([-a-zA-Z0-9]+)\\.)+(?!\\d+$)[a-zA-Z0-9]{2,}$', 'gm')
const str = `Aba@example.com
test@test-test.com.com
test.abc-efg'@test-test.com.com.01111co
simple@example.com
very.common@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
example-indeed@strange-example.com
example@s.example
Abc.example.com
A@b@c@example.com
just"not"right@example.com
this is"not\\allowed@example.com
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
john..doe@example.com
john.doe@example..com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}