$re = '/(?:(?<=libr\()|(?<=req\())[^)]+/m';
$str = 'libr(lib1), libr(lib2), libr(lib3), req(reqlib), libra(nonlib)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);