re = /(?:(?<=libr\()|(?<=req\())[^)]+/m
str = 'libr(lib1), libr(lib2), libr(lib3), req(reqlib), libra(nonlib)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end