import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![.!#$%&'*+\\/=?^_`\\{|\\}~-])(?:[a-zA-Z0-9]|(?:(?:([.])(?!\\1)|[!#$%&'*+\\/=?^_`\\{|\\}~-]))(?!@)){1,64}@(?=.{1,255}$)(?!\\d+$)[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)*$";
final String string = "joe.johnson@example.com\n"
+ "-joe.johnson-@example.com\n"
+ "joe.johnson@example.com\n"
+ "joe.johnson@-example.com\n"
+ "joe.johnson@example.com-\n"
+ "joe..johnson@example.com\n"
+ "joe.-johnson@example.com\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}