const regex = /^(?![.!#$%&'*+\/=?^_`{|}~-])(?:[a-zA-Z0-9]|(?:(?:([.])(?!\1)|[!#$%&'*+\/=?^_`{|}~-]))(?!@)){1,64}@(?=.{1,255}$)(?!\d+$)[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![.!#$%&\'*+\\\/=?^_`{|}~-])(?:[a-zA-Z0-9]|(?:(?:([.])(?!\\1)|[!#$%&\'*+\\\/=?^_`{|}~-]))(?!@)){1,64}@(?=.{1,255}$)(?!\\d+$)[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)*$', 'gm')
const str = `joe.johnson@example.com
-joe.johnson-@example.com
joe.johnson@example.com
joe.johnson@-example.com
joe.johnson@example.com-
joe..johnson@example.com
joe.-johnson@example.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}