package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\"(.*?)\")|(\'(.*?)\')`)
var str = `var A="&";var B="(";var D="[]";var X="'";var W='&';var Q='';var STR="'";var Q="'******'";var G="^";var F="...";var T='$';var wm = "()"
console.log(A + B + D + "^" + wm + '#');`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}