$re = '/(\"(.*?)\")|(\'(.*?)\')/m';
$str = 'var A="&";var B="(";var D="[]";var X="\'";var W=\'&\';var Q=\'\';var STR="\'";var Q="\'******\'";var G="^";var F="...";var T=\'$\';var wm = "()"
console.log(A + B + D + "^" + wm + \'#\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);