using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Weather now : (.*) Weather tomorrow : .*";
string input = @"Weather now : Mildly-sunny34 Weather tomorrow : Cloudy";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}