$re = '/Weather now : (.*) Weather tomorrow : .*/';
$str = 'Weather now : Mildly-sunny34 Weather tomorrow : Cloudy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);