package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\b`)
var str = `123456
1234
123.56789
Joe1234
2way`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}