$re = '/\b\d+\b/m';
$str = '123456
1234
123.56789
Joe1234
2way';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);