import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z]{2}[0-9]{2}(?:[ ]?[0-9]{4}){4}(?!(?:[ ]?[0-9]){3})(?:[ ]?[0-9]{1,2})?\\b";
final String string = "This IBAN looks ok AB12 1234 1234 1234 1234 at first glance\n"
+ "Also this AB12 1234 1234 1234 1234 1 seems fine\n"
+ "And AB12 1234 1234 1234 1234 12 passes\n\n\n"
+ "Or without spaces AB123456789012345678\n"
+ "We'll find this AB1234567890123456789 also\n"
+ "Even the longer AB12345678901234567890 matches\n\n"
+ "Not allowed\n"
+ "------------\n"
+ "AB12 1234 1234 1234 123 (to few numbers)\n"
+ "AB12 1234 1234 1234 1234 123 (to many numbers) \n"
+ "1234 1234 1234 1234 1234 (starts with numbers)\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}