$re = '/\b[A-Z]{2}[0-9]{2}(?:[ ]?[0-9]{4}){4}(?!(?:[ ]?[0-9]){3})(?:[ ]?[0-9]{1,2})?\b/m';
$str = 'This IBAN looks ok AB12 1234 1234 1234 1234 at first glance
Also this AB12 1234 1234 1234 1234 1 seems fine
And AB12 1234 1234 1234 1234 12 passes
Or without spaces AB123456789012345678
We\'ll find this AB1234567890123456789 also
Even the longer AB12345678901234567890 matches
Not allowed
------------
AB12 1234 1234 1234 123 (to few numbers)
AB12 1234 1234 1234 1234 123 (to many numbers)
1234 1234 1234 1234 1234 (starts with numbers)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);