package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4}){1}($|\;([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4}))+)$`)
var str = `test.namex@society.co.uk;john.doe@mail.fr;iris.queen@sun.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}