import Foundation
let pattern = #"\b(?:(?:[a-f\d]{2})(?:[:-]|)){6}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text...
DE-AD-BE-EF-00-02
12:34:56:78:9A:BC
AA:BB:CC:DD:EE:FF
DE:AD:BE:EF:00:01
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)