import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "FIRST\\|(?:(?!SECOND\\|[^B])[\\S\\s])*?SECOND\\|B";
final String string = "FIRST|[some text here] (newline)\n"
+ "[insert text here] (newline)\n"
+ "SECOND|A (newline)\n\n"
+ "FIRST|[some text here] (newline)\n"
+ "[insert text here] (newline)\n"
+ "SECOND|B (newline)\n\n"
+ "FIRST|[some text here] (newline)\n"
+ "[insert text here] (newline)\n"
+ "SECOND|A (newline)\n\n"
+ "FIRST|[some text here] (newline)\n"
+ "[insert text here] (newline)\n"
+ "SECOND|B (newline)\n\n"
+ "FIRST|[some text here] (newline)\n"
+ "[insert text here] (newline)\n"
+ "SECOND|A (newline)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}