package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(((http|https):\/\/)|(\/)|(..\/))(\w+:?\w*@)?(\S+)(:\d+)?(\/|\/([\w#:.?+=&%@!\-\/]))?`)
var str = `http://regex101.com/r/kL2gL2/1
http://regex101.com/r/kL2gL2/1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}