re = /(((http|https):\/\/)|(\/)|(..\/))(\w+:?\w*@)?(\S+)(:\d+)?(\/|\/([\w#:.?+=&%@!\-\/]))?/
str = 'http://regex101.com/r/kL2gL2/1
http://regex101.com/r/kL2gL2/1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end