# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\G(?!^)|STRING).*?)\)/$1/gm;t' <<< "foo)bar)baz STRING foo)bar)baz)"