re = /((?:\G(?!^)|STRING).*?)\)/m
str = 'foo)bar)baz STRING foo)bar)baz)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result